Ticket 337813 - Inbound call Outage
Incident Report for FirstComm Network Status
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:55 CDT
Identified
We have confirmed that an upstream carrier is having an outage affecting inbound calls to FirstComm. Outbound calls are completing as normal. Currently this appears to be primarily impacting inbound calls from cellular carriers.
Posted Jun 20, 2022 - 08:22 CDT